Introduction

GE-Path

v 1.4.3

August 2008

GE-Path is a freeware and may be distributed freely (credits intact).

No warranty of any kind is made for any use.

homepage: http://www.sgrillo.net/googleearth/gepath.htm

Support:

R.Sgrillo

Cocoa Research Center

ricardo.sgrillo@terra.com.br

This utility is intended for the users of GoogleEarth free version.

Features

  • Read kml file saved by Google Earth (v 1.2.0)
  • Link the placemarks (simple or arrowed lines) (v 1.2.0)
  • Add sequential numbers and/or append the coordinates to the placemark's names (v 1.2.0)
  • Calculate distances between placemarks (v 1.2.0)
  • Calculate route (bearing) to the next placemark (v 1.2.0)
  • Add distances, routes and/or coordinates to the placemarks description (v 1.2.0)
  • Draw horizontal and/or vertical grids (equally spaced or not) (v 1.2.0)
  • Draw regular polygons around placemarks (v 1.2.0)
  • Calculate path's length/perimeter (v 1.2.0)
  • Calculate the area delimited by several placemarks (or by path's waypoints) (v 1.2.0)
  • Save the resulting kml file and export it to Google Earth (v 1.2.0)
  • Save data as txt (comma delimited) (v 1.3.0)
  • Copy from clipboard (v 1.3.0)
  • Export data to Excel (v 1.3.0)
  • Directly input data (v 1.3.0)
  • Edit data (v 1.3.0)
  • Fill polygon (v 1.3.0)
  • Use altitude for paths, polygons and place names/icons (v 1.4.0)
  • Automatic configuration (and restoration) of the system decimal separator (v 1.4.0)
  • Choice of width of the Path's line and polygon outline (v 1.4.0)
  • Compatible with Google Earth version 4 (v 1.4.1)
  • Fixed bug for Small Area (v 1.4.3)

The users of GoogleEarth Plus and Pro could also use it to calculate area and/or total path length or perimeter from saved Path files (kml).

Copyright © <2008>, <R.Sgrillo>

This help file has been generated by the freeware version of HelpNDoc


Input Data

Input File

A. kml files

1. PlaceMarks File (GE Free, Plus or Pro)

The placemarks file has to contain only placemarks and no other items (paths, overlays, etc)

To generate an input file for GE-Path:

1. Create a folder in GE (menu Add/Folder or right click in My Places and New/Folder)

2. Put your placemarks in this folder (create, move or paste placemarks in the folder)

3. Save the Folder as kml

Notes:

a. Even if you have a single placemark, it has to be located inside a folder.

b. The placemarks has to be sequentially ordered in the folder if you choose the makepath and/or area/perimeter options

c. The grid and path options requires at least two placemarks in the folder

d. The area option requires at least three placemarks in the folder

2. Path File (GE Plus or Pro)

A path file can be generated with GE Plus and Pro.

The path file has to contain a single path and no other items (placemarks, overlays, etc)

GE-Path will recognize paths with single line coordinates.

<coordinates>

-0.1212441548592693,51.05836535232496,0 -0.1211842654650042,51.05803141913374,0 ....

</coordinates>

Paths with multi lines coordinates (line feed, paragraph, break characters) will not be recognized

<coordinates>

-0.1212441548592693,51.05836535232496,2000

-0.1211842654650042,51.05803141913374,2000

-0.1207286007679613,51.05770827344986,2000

-0.1201915784528325,51.05751902262342,3000

-0.1199061589486803,51.05719154843076,5000

</coordinates>

The kml tags <LineString> and <LinearRing> will be recognized.

GE-Path will read groups of three coordinates (lon, lat and alt) and create a placemark for each group (the placemarks will be named with sequential numbers e have the default icon).

If you dont' want to show the place (waypoint) names and icons in the processed file check the Remove names and icons checkbox in the Place Names option group

Warning: The make a tour in the path-file generated by GE-Path, select ONLY the Path on-off icon.

NOTE: GE-Path will recognize files composed only of placemarks or path. Image or screen overlays, etc. may generate a file open error.

B. Text files

Version 1.4.0 will read txt files saved by the previous versions.

Text files have to be in the following format:

place name, place description, latitude, longitude, altitude

Notes:

1. The fields have to be comma delimited

2. The decimal separator has to be a dot

3. The coordinates have to be in decimal degrees

4. The place names and description may be blank

4. The altitudes have to be in meters

C. Pasting data

You can paste data from Excel, Word (table) and other applications. You have always to select and copy five columns from the original application. The data has to be in the same sequence as the text files.The two first columns may also be blank. In GE-Path click on Paste grid from the clipboard

D. Entering new data

You can enter directly your data into the application table.


Options

  • Place Names
  • Place Descriptions
  • Make Path
  • Make Grid
  • Make Circles
  • Path's Area and Distance
  • References


Place Names

A. Add sequential numbers to names

B. Append Coordinates to names

C. Remove names and icons

This option has utility if your input file is a path file, or if you want to generate a path file

C. Altitude mode

Select the altitude mode for the place name/icon location


Place Descriptions

Append to existing descriptions

Any of the five last descriptions will be appended to existing description If Append to existing descriptions is checked.

A. Don't change

Leave descriptions as they are in the input file

B. None

Remove descriptions

C. Coordinates

D. Distance to next place

E. Route to next place

F. Coordinates, distance and route


Make Path

The option Remove Names and Icons was checked

You can chose the line width of the path. However the graphics mode of Google Earth has to be settled in OpenGL to show line width different from one.


Make Grid

If you enter "Distance between lines" you have to choose also the distance unit in the bottom of the form.


Make Polygons

This option is to draw regular polygons around each placemark.

Length is the distance from the center of the polygon two one vertex. For circles length will be the radius. Don't forget to choose the distance unit in the bottom of the form (Area/Perimeter frame).

Segments are the sides of the polygon. Polygons with 20 or more sides (segments) looks very much as circles.

You can chose the line width of the polygon outlines. However the graphics mode of Google Earth has to be settled in OpenGL to show line width different from one.

If you choose to fill the polygons and they show strange pattern inside then uncheck the option "Terrain" in GE.


Perimeter and Area

To calculate path's length or perimeter it is necessary at least two placemarks. To calculate area it is necessary at least three placemarks.

The perimeter and area will be calculated according to the sequential order of the placemarks

There are available two different methods for area calculation, according to the size of the area:

1. Large Area => For areas greater than 10 km² (10,000,000 m² or 2,500 Acres or 1,000 ha): Use the spherical polygon method (see References )

2. Small Area => For areas smaller than 1 km² (10,000,000 m² or 2,500 Acres or 1,000 ha): Convert the coordinates to UTM (WGS84) and use a standard polygon's area calculation method (see References )

If Create Placemark for area is checked a label, with the area value, will be located more or less in the center of the polygon. Both, area and perimeter, will be shown in the GE's placemark panel.

The area and/or perimeter will be calculated when you press run. You will be prompted for a file name to save the file. However, if you want only calculate area/perimeter and don't want to save the file, check the Don't save the kml file. Show area and perimeter only checkbox.


References

Distance and route

Aviation Formulary V1.42 By Ed Williams (http://williams.best.vwh.net/avform.htm)

Great Circle Calculator. By Ed Williams (http://williams.best.vwh.net/gccalc.htm)

Area

Large:

Miller, Robert D. 1994. Computing the Area of a Spherical Polygon In: Heckbert, P.S. ed. Graphics Gems IV. Academic Press, Boston

Corresponding Fortran Program at: http://www.scs.fsu.edu/~burkardt/f_src/geometry/geometry.f90

Small:

University of Wisconsin - Green Bay. 2008. Converting UTM to Latitude and Longitude (Or Vice Versa) at http://www.uwgb.edu/dutchs/UsefulData/UTMFormulas.htm

Sunday, Dan. 2008. Algorithm 1: Area of Triangles and Polygons (2D & 3D) at http://www.softsurfer.com/Archive/algorithm_0101/algorithm_0101.htm#3D%20Polygons

Double Precision trigonometric functions

Probability.dll

Delphi LabTools - Probabilities + Math387 dll for Visual Basic and Microsoft Excel Add-In - 11th August, 2004

For non-commercial purposes the use of the package is free

(http://www.dewresearch.com/downloads-delphi.html)